Unable to open database file

Topics: Help / Support
Apr 6, 2016 at 6:51 PM
When I try to launch Yamster, I get the error: unable to open database file

I can open the program with my Administor account but that account doesn't have Internet access and isn't Yammer enabled.

Any suggestions?
Coordinator
Apr 7, 2016 at 1:31 AM
Hmm... I haven't seen that problem before. The database file is stored in your Windows "Documents" folder, under a subfolder called "Yamster". Can you check whether that exists? If so, try deleting the "Yamster" folder and then re-running the application. (Maybe it was created with some special permissions?)

Also, what version of Windows are you using? Have you tried this on a different PC?
Apr 7, 2016 at 8:33 PM
Edited Apr 7, 2016 at 8:33 PM
I deleted the folder. It was re-created containing a file called Settings.xml. I get the same error. My Documents folder is on a network drive.

I am running Win7SP1 7601

I do not currently have another computer on which to test but could next week.
Coordinator
Apr 8, 2016 at 9:34 AM
Edited Apr 8, 2016 at 9:35 AM
There may be problems with storing Yamster's database file on a network drive. The database expects the file to support locking features that a network drive may not be able to provide.

If your Documents folder must be on a network drive, what I can do is add an option to Settings.xml that allows you to specify a custom location for your database file, which should be on your local hard drive. Would that work?
Apr 8, 2016 at 1:35 PM
That sounds like it might work. I have no control over where my Documents folder lives :(
Coordinator
Apr 9, 2016 at 8:03 AM
Edited Apr 9, 2016 at 8:05 AM
Please try installing Yamster! 2.9.1. I added a new setting that allows you to move the database to your local disk. You will need to run the application at least once to upgrade your settings file. As noted above, Yamster's configuration file is called "Settings.xml" and is located under your "Documents" folder and "Yamster" subfolder. If you edit the file using Notepad you should see something like this:
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<YamsterSettings Version="1.3">
    <YamsterApplication ChatPaneWidth="500" ShowUnreadThreadCount="true" />
    <YammerServiceUrl>https://www.yammer.com</YammerServiceUrl>
    <DatabaseFilename>Yamster.db</DatabaseFilename>
    <Authentication>
        <AppClientId></AppClientId>
        <OAuthToken ProtectTokenWhenSaving="true"></OAuthToken>
    </Authentication>
</YamsterSettings>
To relocate your database, first you need to create a new folder on your local hard drive, let's say for example "C:\YamsterData". Make sure that you have granted yourself full permissions to this folder. Then edit the above Settings.xml to have this setting:
    <DatabaseFilename>C:\YamsterData\Yamster.db</DatabaseFilename>
The next time you run Yamster, it should automatically create a new Yamster.db in this location. Let me know if this fixes your issue. Thanks!
Marked as answer by pgonzal on 4/11/2016 at 12:49 AM
Apr 9, 2016 at 8:44 PM
Thanks! I'll try this out when I get into the office on Monday!


Apr 11, 2016 at 2:22 PM
That worked! Thank you.